Skip to main content
← All vulnerabilities
CVE-2022-0154

An issue has been discovered in GitLab affecting all versions starting from 7.7 before 14.4.5, all versions starting from 14.5.0 before 14.5

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.4.5, 14.5.3, 14.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 7.7 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was vulnerable to a Cross-Site Request Forgery attack that allows a malicious user to have their GitHub project imported on another GitLab user account.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 7.7 · fixed in 14.4.5; From 14.5.0 · fixed in 14.5.3; From 14.6.0 · fixed in 14.6.2

References 3

gitlab.com

hackerone.com