Skip to main content
← All vulnerabilities
CVE-2022-0152

An issue has been discovered in GitLab affecting all versions starting from 13.10 before 14.4.5, all versions starting from 14.5.0 before 14

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.6.2, 14.5.3, 14.4.5
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 13.10 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was vulnerable to unauthorized access to some particular fields through the GraphQL API.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 14.6 · fixed in 14.6.2; From 14.5 · fixed in 14.5.3; From 13.10 · fixed in 14.4.5

References 2

gitlab.com