Skip to main content
← All vulnerabilities
CVE-2022-0151

An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.4.5, all versions starting from 14.5.0 before 14

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.4.5, 14.5.3, 14.6.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab affecting all versions starting from 12.10 before 14.4.5, all versions starting from 14.5.0 before 14.5.3, all versions starting from 14.6.0 before 14.6.2. GitLab was not correctly handling requests to delete existing packages which could result in a Denial of Service under specific conditions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 12.10 · fixed in 14.4.5; From 14.5.0 · fixed in 14.5.3; From 14.6.0 · fixed in 14.6.2

References 2

gitlab.com