Skip to main content
← All vulnerabilities
CVE-2022-0019

GlobalProtect App: Insufficiently Protected Credentials Vulnerability on Linux

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.3.2, 5.1.10
None on Exploit-DB, Metasploit or GitHub

Summary

An insufficiently protected credentials vulnerability exists in the Palo Alto Networks GlobalProtect app on Linux that exposes the hashed credentials of GlobalProtect users that saved their password during previous GlobalProtect app sessions to other local users on the system. The exposed credentials enable a local attacker to authenticate to the GlobalProtect portal or gateway as the target user without knowing of the target user’s plaintext password. This issue impacts: GlobalProtect app 5.1 versions earlier than GlobalProtect app 5.1.10 on Linux. GlobalProtect app 5.2 versions earlier than and including GlobalProtect app 5.2.7 on Linux. GlobalProtect app 5.3 versions earlier than GlobalProtect app 5.3.2 on Linux. This issue does not affect the GlobalProtect app on other platforms.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Palo Alto Networks GlobalProtect App

    From 5.3 · fixed in 5.3.2; From 5.2 · through 5.2.7; From 5.1 · fixed in 5.1.10

References 1

security.paloaltonetworks.com