Skip to main content
← All vulnerabilities
CVE-2021-45943PYSEC-2022-43065BIT-GDAL-2021-45943

GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFrom

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.4.1
None on Exploit-DB, Metasploit or GitHub

Summary

GDAL 3.3.0 through 3.4.0 has a heap-based buffer overflow in PCIDSK::CPCIDSKFile::ReadFromFile (called from PCIDSK::CPCIDSKSegment::ReadFromFile and PCIDSK::CPCIDSKBinarySegment::CPCIDSKBinarySegment).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • gdalPyPI

    From 3.3.0 · fixed in 3.4.1

References 11

GitHub · google/oss-fuzz-vulns

bugs.chromium.org

GitHub · OSGeo/gdal

lists.debian.org

lists.fedoraproject.org

oracle.com

debian.org

security.gentoo.org