Skip to main content
← All vulnerabilities
CVE-2021-44730

snapd could be made to escalate privileges and run programs as administrator

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub

Summary

snapd 2.54.2 did not properly validate the location of the snap-confine binary. A local attacker who can hardlink this binary to another location to cause snap-confine to execute other arbitrary binaries and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Canonical Ltd. snapd

    through 2.54.2

References 6

ubuntu.com

openwall.com

lists.fedoraproject.org

debian.org