Skip to main content
← All vulnerabilities
CVE-2021-43803GHSA-25MP-G6FV-MQXX

Unexpected server crash in Next.js

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.1.3, 12.0.5
None on Exploit-DB, Metasploit or GitHub

Summary

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • vercel next.js

    From 11.1.0 · fixed in 11.1.3; From 12.0.0 · fixed in 12.0.5

  • nextnpm

    From 12.0.0 · fixed in 12.0.5

  • nextnpm

    From 0.9.9 · fixed in 11.1.3

References 5

GitHub · vercel/next.js