Skip to main content
← All vulnerabilities
CVE-2021-43561GHSA-HFM8-2Q22-H7HV

An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.5.1, 2.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • pegasus/google-for-jobsPackagist

    fixed in 1.5.1

  • pegasus/google-for-jobsPackagist

    From 2.0.0 · fixed in 2.1.1

References 1

typo3.org