Skip to main content
← All vulnerabilities
CVE-2021-43559GHSA-3JRJ-X6CJ-97CPBIT-MOODLE-2021-43559

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.11.4, 3.10.8, 3.9.11
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.11 · fixed in 3.11.4

  • moodle/moodlePackagist

    From 3.10 · fixed in 3.10.8

  • moodle/moodlePackagist

    From 3.9 · fixed in 3.9.11

References 2

bugzilla.redhat.com

moodle.org