Skip to main content
← All vulnerabilities
CVE-2021-4315PYSEC-2023-43GHSA-9MQ4-9556-6QXQ

NYUCCL psiTurk experiment.py special elements used in a template engine

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.2.1
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerability has been found in NYUCCL psiTurk up to 3.2.0 and classified as critical. This vulnerability affects unknown code of the file psiturk/experiment.py. The manipulation of the argument mode leads to improper neutralization of special elements used in a template engine. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.1 is able to address this issue. The name of the patch is 47787e15cecd66f2aa87687bf852ae0194a4335f. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-219676.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • NYUCCL psiTurk

    3.0, 3.1, 3.2

  • psiturkPyPI

    fixed in 3.2.1

  • psiturkPyPI

    fixed in 3.2.1

References 5

vuldb.com

GitHub · NYUCCL/psiTurk