Skip to main content
← All vulnerabilities
CVE-2021-4231GHSA-C75V-2VQ8-878F

Angular Comment cross site scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.0.5, 11.1.0-next.3, 10.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • unspecified Angular

    11.0.0, 11.0.1, 11.0.2, 11.0.3, 11.0.4, 11.1.0-next.0, 11.1.0-next.1, 11.1.0-next.2

  • @angular/corenpm

    From 11.0.0 · fixed in 11.0.5

  • @angular/corenpm

    From 11.1.0-next.0 · fixed in 11.1.0-next.3

  • @angular/corenpm

    fixed in 10.2.5

References 4

GitHub · angular/angular

security.snyk.io

vuldb.com