CVE-2021-41561GHSA-GC67-CRQ6-HGH5
Apache Parquet-MR potential DoS in case of malicious Parquet file
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.12.2, 1.11.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Improper Input Validation vulnerability in Parquet-MR of Apache Parquet allows an attacker to DoS by malicious Parquet files. This issue affects Apache Parquet-MR version 1.9.0 and later versions.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Parquet
From 1.9.0
- org.apache.parquet:parquetMaven
From 1.12.0 · fixed in 1.12.2
- org.apache.parquet:parquetMaven
fixed in 1.11.2