Skip to main content
← All vulnerabilities
CVE-2021-41125GHSA-JWQP-28GF-P498PYSEC-2021-363

HTTP authentication credential leak to target websites in scrapy

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.1, 2.5.1
None on Exploit-DB, Metasploit or GitHub

Summary

Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • scrapy scrapy

    fixed in 1.8.1; From 2.0.0 · fixed in 2.5.1

  • scrapyPyPI

    fixed in 1.8.1

  • scrapyPyPI

    From 2.0.0 · fixed in 2.5.1

  • scrapyPyPI

    fixed in 1.8.1; From 2.0.0 · fixed in 2.5.1

References 5

GitHub · scrapy/scrapy

w3lib.readthedocs.io

doc.scrapy.org

lists.debian.org