Skip to main content
← All vulnerabilities
CVE-2021-40331GHSA-VJR2-WPFH-5R9P

Permissions problem in the Apache Ranger Hive Plugin

Published
Last modified
published
Not listed in CISA KEV
Critical (apache)
Fix
Fixed in 2.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

An Incorrect Permission Assignment for Critical Resource vulnerability was found in the Apache Ranger Hive Plugin. Any user with SELECT privilege on a database can alter the ownership of the table in Hive when Apache Ranger Hive Plugin is enabled This issue affects Apache Ranger Hive Plugin: from 2.0.0 through 2.3.0. Users are recommended to upgrade to version 2.4.0 or later.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Ranger Hive Plugin

    From 2.0.0 · through 2.3.0

  • org.apache.ranger:ranger-hive-pluginMaven

    From 2.0.0 · fixed in 2.4.0

References 1

lists.apache.org