CVE-2021-40143GHSA-F34X-8PF6-QC9C
Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.34.0-01
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Sonatype Nexus Repository 3.x through 3.33.1-01 is vulnerable to an HTTP header injection. By sending a crafted HTTP request, a remote attacker may disclose sensitive information or request external resources from a vulnerable instance.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- org.sonatype.nexus:nexus-repositoryMaven
From 3.0.0 · fixed in 3.34.0-01