Skip to main content
← All vulnerabilities
CVE-2021-39944

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.0 before 14.3.6, all versions starting from 14.4 before

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.3.6, 14.4.4, 14.5.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.0 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. A permissions validation flaw allowed group members with a developer role to elevate their privilege to a maintainer on projects they import

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 11.0 · fixed in 14.3.6; From 14.4 · fixed in 14.4.4; From 14.5 · fixed in 14.5.2

References 3

gitlab.com

hackerone.com