Skip to main content
← All vulnerabilities
CVE-2021-39938

A vulnerable regular expression pattern in GitLab CE/EE since version 8.15 before 14.3.6, all versions starting from 14.4 before 14.4.4, all

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.5.2, 14.4.4, 14.3.6
None on Exploit-DB, Metasploit or GitHub

Summary

A vulnerable regular expression pattern in GitLab CE/EE since version 8.15 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2, allows an attacker to cause uncontrolled resource consumption leading to Denial of Service via specially crafted deploy Slash commands

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 14.5 · fixed in 14.5.2; From 14.4 · fixed in 14.4.4; From 8.15 · fixed in 14.3.6

References 2

gitlab.com