Skip to main content
← All vulnerabilities
CVE-2021-39880GHSA-W6PV-C757-6RGRBIT-GITLAB-2021-39880

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all ve

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 14.2.2, 14.1.4, 14.0.9, 2.1.0
None on Exploit-DB, Metasploit or GitHub

Summary

A Denial Of Service vulnerability in the apollo_upload_server Ruby gem in GitLab CE/EE all versions starting from 11.9 before 14.0.9, all versions starting from 14.1 before 14.1.4, and all versions starting from 14.2 before 14.2.2 allows an attacker to deny access to all users via specially crafted requests to the apollo_upload_server middleware.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • GitLab GitLab

    From 14.2 · fixed in 14.2.2; From 14.1 · fixed in 14.1.4; From 11.9 · fixed in 14.0.9

  • apollo_upload_serverRubyGems

    fixed in 2.1.0

References 3

gitlab.com

hackerone.com